Post a reply
  •  Bug reports

Type the text circled in red below:


Please remember some basic forum etiquette guys.
No guild advertisements, they go in this topic only.

Latest posts review Expand
Caperfin
5 hours ago
The icons are clipping into the guide titles. or is it just me?

Image
Gallow
1 week ago
Old guides inside the Guides section have their old thumbnails (?Not sure what they are called) merged with the title on desktop.
Using Chrome.
Can't check mobile atm, but pretty sure the same thing exists there as well.



Edit: imgur is crazy.
https://i.imgur.com/CgaKGvx.jpg
Gallow
2 weeks ago
Thanks for the reply! Actually it's one per page I think, because the below one appears to be linked with my original post as well.

3rd
1
2
3
4
5
6
7
Oh well!

Edit: @teebling How about the number of the tabbed navigation boxes? Currently the max. number seems to be 20.
I was wondering if it's possible to increase the limit (really... to 100 or something) because I would like to write my story in tabbed navs as seen here:

viewtopic.php?f=10&t=2013#Start

And 20 means I won't be able to use that look.

Thanks!
teebling
2 weeks ago
Gallow wrote:
2 weeks ago
Hey @teebling is the following a bug?

Lets say we use a tabnav on a page. I'll use the Authors page example:

1st tab
Blabla
Rarara
Gagag
Pagagag
Bebebebe
Rorororo
Nonono
If I also have a tabnav on my signature (or two tabnavs in one page), they stop working. Or more like, they start linking to each other. See below:

2nd tab
11
22
33
44
55
66
77
Yeah it's a limitation I'm afraid - one table per post I think.
Gallow
2 weeks ago
Hey @teebling is the following a bug?

Lets say we use a tabnav on a page. I'll use the Authors page example:

1st tab
Blabla
Rarara
Gagag
Pagagag
Bebebebe
Rorororo
Nonono
If I also have a tabnav on my signature (or two tabnavs in one page), they stop working. Or more like, they start linking to each other. See below:

2nd tab
11
22
33
44
55
66
77
daisyKutter
3 weeks ago
On Firefox Android there is no horizontal scroll under current users:

Image
teebling
1 month ago
Mourist wrote:
1 month ago
I sent a message to someone recruiting for their guild and it never moved from outbox to sent. So is it sent? What's the difference between outbox and sent?
If it’s in outbox they haven’t read it yet.
Mourist
1 month ago
I sent a message to someone recruiting for their guild and it never moved from outbox to sent. So is it sent? What's the difference between outbox and sent?
teebling
1 month ago
Zahhibb wrote:
1 month ago
it doesn't work for me to change profile banner. Every time I select a new image and press submit, my old banner (which I have selected to be deleted previously) is there instead. I've tried several times but it doesn't seem to work.
Refresh your browser cache.
Zahhibb
1 month ago
it doesn't work for me to change profile banner. Every time I select a new image and press submit, my old banner (which I have selected to be deleted previously) is there instead. I've tried several times but it doesn't seem to work.
teebling
1 month ago
Nukez wrote:
1 month ago
Hey, i can confirm what "Guest" said. I wanted to register and got stuck at "Complete this sentence: World of Wacraft ' '". How would I know that I have to fill in "vanilla" here?

It would be great if there's a hint or something in it.

I bet a few users already failed to register because of that ;)
Classic, Vanilla, 1.13 are all possible and reasonable answers at this time. The question will be restructured and re-presented in upcoming patch 1.10 however.
Nukez
1 month ago
Hey, i can confirm what "Guest" said. I wanted to register and got stuck at "Complete this sentence: World of Wacraft ' '". How would I know that I have to fill in "vanilla" here?

It would be great if there's a hint or something in it.

I bet a few users already failed to register because of that ;)
Guest
1 month ago
when posting as a guest, i found the spam questino to be fuckin' insane dude.

the answer is vanilla but the questino itself is retarded. it's worded as though you speak ebonics or your native language is not English.

+1 vote for new question

"Which expansion is this website about?"
"What expansion is barrens.chat website about?"
"What patch is 1.12.1 usually referred to?"
teebling
1 month ago
Thanks @Flerex will implement this extra barrier in 1.10
Flerex
1 month ago
If those alternatives are not good for you you can do what I do in my blog. As bots usually do not support JavaScript, create a hidden field that has an empty value and a name of a common field (age, for example).

Code: Select all

<input type="hidden" name="age" value="">
Then, with JavaScript, modify the value of this field to an arbitrary one via an event listener.

Code: Select all

document.querySelector('button[type="submit"]').addEventListener('click', _ => {
    document.querySelector('input[type="hidden"][name="age"]').value = 5063;
});
Then in your backend you just have to check that that value is what you expected. If it is not, just return a blank page so that bots can't go back and try to fix the form.

Code: Select all

if(!isset($_POST['age']) || intval($_POST['age')] !== 5063) { // Or equivalent method in your platform / framework
    die();
}
The only problems with this method are:
  • It's too simple. It won't prevent bots that are made specifically to attack your site, as bypassing it is pretty simple. However, if you get more SPAM you would know somebody is attacking you on purpose.
  • Users that do not have JavaScript support would instantly considered spammers and wouldn't be able to complete the forms. This shouldn't be a problem in most cases as every single browser nowadays supports JavaScript but still should be something to consider.
teebling
1 month ago
@Gallow and @Flerex please see my explanation here. Neither are a perfect solution but Q+A is much more solid until the answer is found, at which point it needs to be changed. The problem is I don't know when they have the answer, because now the bots lie dormant for a few days before posting, so I don't know how many spam bots have registered in the period since the answer was broken.
Flerex
1 month ago
reCaptcha v2 can be of use to prevent spambots.
Gallow
1 month ago
Hey @teebling not really a "bug", but do you have any plans for the recent massive spambots that are advertising to phishing links?

I can see on the account registration page that you have an anti-spambot question like:
Confirmation of registration
This is a site about World of Warcraft...:
Which I believe is static (so the answer is always the same?), so it's very easy once the bots figure out the answer.

I don't have much experience with phpBB, but according to their forum post here: https://www.phpbb.com/community/viewtopic.php?t=2419551

the built in Q&A should be blocking the bots effectively.
webmaster
1 month ago
I'm unable to follow a user, or I've found it very hard to learn how to do it. Usually I just visit a profile page and there'd be a button or something.

How do I follow my barrens chat forum buddies and get updates when they make comments / posts? Why was it disabled /removed?

https://www.phpbb.com/about/features/#friendfoe

p.s. - i see in the left sidebar, I can "message" but nothing else. i'm quite certain the phpBB forum software allows for this. is follow forum member disabled?
Telvaine
1 month ago
That did work thank you!
teebling
1 month ago
Telvaine wrote:
1 month ago
Right now any time I try to access the home page on my phone I'm getting an error message. I can still access any other part of the forum. It says:

General Error
SQL ERROR [mysqli]
Connection refused [2002]
An sql error occurred while fetching this page. Please contact an administrator of this problem persists.

Help?
Refresh your browser cache, should do the trick.
Telvaine
1 month ago
Right now any time I try to access the home page on my phone I'm getting an error message. I can still access any other part of the forum. It says:

General Error
SQL ERROR [mysqli]
Connection refused [2002]
An sql error occurred while fetching this page. Please contact an administrator of this problem persists.

Help?
teebling
2 months ago
res wrote:
2 months ago
Only the first mention of a link shortens to the name of the spell/item. Mouseover still works on subsequent wowhead links but they will stay a link.

example:

https://classic.wowhead.com/spell=16857 ... fire-feral

https://classic.wowhead.com/spell=16857 ... fire-feral

https://classic.wowhead.com/item=8190/hanzo-sword

https://classic.wowhead.com/item=8190/hanzo-sword

If this isn't a bug then how do I keep the subsequent links from becoming full urls?
I wasn't aware of this and haven't seen it in the wild or reproduced like this either. Not sure what is going on to be honest but will investigate for patch 1.10 bug fixing.

Thing is that the whole javascript/CSS is not my own and it's not even hosted on my server - it's all on wowhead, so this is most likely a bug on their side which I'll have to tell them about once I've had a good look at my own implementation.

Hanzo Sword

Hanzo Sword

If you encase them in URL tags they seem to work independently:

Code: Select all

[url=https://classic.wowhead.com/item=8190/hanzo-sword]Hanzo Sword[/url]

[url=https://classic.wowhead.com/item=8190/hanzo-sword]Hanzo Sword[/url]
Looks like their icons aren't working at the moment either. This is usually a short term thing from what I've noticed though.

Could just be a temporary thing as well.
res
2 months ago
Only the first mention of a link shortens to the name of the spell/item. Mouseover still works on subsequent wowhead links but they will stay a link.

example:

https://classic.wowhead.com/spell=16857 ... fire-feral

https://classic.wowhead.com/spell=16857 ... fire-feral

https://classic.wowhead.com/item=8190/hanzo-sword

https://classic.wowhead.com/item=8190/hanzo-sword

If this isn't a bug then how do I keep the subsequent links from becoming full urls?
aeh
2 months ago
Ubuntu 18.04 - Firefox Quantum 67.0.4 (64-bit)
Also tested on
macOS newest Opera, newest Version